We are very sorry for the disruption. Thank you again for your patience. Service is once again working as expected.
Posted Nov 19, 2024 - 17:18 EST
Update
Update - We are getting reports that IMAP and POP services are also affected. Please standby while we continue to investigate.
Posted Nov 19, 2024 - 15:26 EST
Investigating
We are investigating an issue preventing some users from logging into Webmail. HostedEmail is experiencing issues resulting in delayed access to webmail. IMAP and POP services are unaffected. The engineering team has been engaged.